
Guide to Editors of Accessible PDFs 
With the January 1, 2003 implementation of the Ontarians with Disabilities Act, 2001, all documents 
(HTML or PDF) posted to the Internet website must be accessible to all persons including those who must 
use screen readers or other assistive technologies.[1] This document describes the process of creating 
accessible PDFs from correctly authored Microsoft® Word documents (hereafter referred to as Word 
documents). If you are looking to find out how to author a document to create an accessible PDF, you 
should read the "Guide to Authors of Accessible PDFs". 

Overview 
There are several components and procedures that must be in place or followed to enable the creation of 
an accessible PDF including the use the appropriate software, creating structured documents, the use of 
the PDFMaker macro and a final check for Accessibility. In this section, the components and procedures 
will be outlined but the details will be explained in later sections. 

Role of the Editor 
The role of the editor is to take a Word document and create an accessible PDF from it. To do so, there 
are three actions that are performed: check the Word document for proper accessible authoring 
techniques, create the PDF and lastly, run Acrobat’s Accessibility Checker. The Word document must be 
checked to ensure that the proper authoring techniques have been followed. Creating the PDF is a simple 
matter but it is the role of the editor because it can only be done after the first step, checking the Word 
document. The final step is to run Acrobat’s Accessibility Checker to ensure that nothing has been lost in 
the conversion and to correct for items that are known accessibility problems such as document language, 
footnotes and certain font characters. 

The editor may also be the author and therefore, should read and apply the techniques mentioned in the 
"Guide to Authors of Accessible PDFs" document. If the editor has followed the guidelines for authors, 
then the first step, checking the Word document, would not be necessary. 

Tagged PDFs 
Accessible PDFs are tagged PDFs. The process of tagging the document is performed when the PDFs are 
created. The tags are similar to HTML tags which identify components of the document such as headings, 
paragraphs, list items and table cells but unlike HTML, PDF tagging is not a manual process — Acrobat’s 
PDFMaker creates the tags for the PDF document. The presence of the tags make it possible for screen 
reader and Braille technologies to identify the different components of the document and pass that 
information to the user (reader). 

PDF tags were introduced with PDF version 1.4. In the same way that Adobe identifies different versions 
of its Acrobat products (versions 3, 4, 5 and 6), the PDF file format also has had different versions 
through its history such as 1.2, 1.3, 1.4 and 1.5. Only Acrobat 5 and later may be used to create accessible 
PDFs as they are the only Acrobat versions that produce PDF files using versions that may be made 
accessible. 

Software 
At the time of this writing, there are only two common software that may be used to create accessible 
PDFs, Microsoft Word 2000 or later and Adobe Acrobat 5.0 or later. This document was written for users 
of Adobe Acrobat 5.05: options and menus have changed in Adobe Acrobat 6 therefore, some of the 
specific techniques have changed. 

Word Processing Software 
Other Adobe products may also be used to create accessible PDFs such as PageMaker or InDesign 
(desktop publishing applications) however, this document will focus on standard word processing 



software. Other word processing software, such as Word 97 or WordPerfect, may be used to create the 
original document but the document must be imported into Word 2000 or later from which the PDF must 
be generated. 

PDF Generation Software 
At the time of writing, only Acrobat 5 and 6 have the features needed to create accessible PDFs. The PDF 
format is an open file format which is maintained by various companies including Adobe. This is useful 
to know because, although there is other software (freeware, shareware and commercial) that may be used 
to create and edit PDF documents, currently, only Adobe Acrobat 5 and 6 can create accessible PDFs. In 
the future, however, other company’s products may evolve to enable the creation of accessible PDFs but 
none have at this time. 

Document Structure 
Document structure should be used properly to make the PDF accessible. It enables the user of screen 
reader software to use the content of the document as much as sighted users may use the content of a 
document. Sighted users use visual cues to gather information about a document such as the size, colour 
and bold style of heading, the use of numbered and bulleted lists and the relationship of a table cell to the 
header cells around it. Screen reader software reads the content and also the structure of the content to 
enable it to inform the user that a heading has been encountered or the headers related to a particular data 
cell in a table. Styles are visual only; structure is needed for screen readers. Techniques on applying 
proper document structure are discussed in the "Guide to Authors of Accessible PDFs". 

Checking the PDF 
Even if all of the proper techniques have been used, you must still check the PDF for Accessibility using 
Acrobat’s Accessibility Checker. This function enables you to determine if something was overlooked or 
didn’t work properly — sometimes the translation from Word to PDF loses some features or settings 
which then have to be tagged manually in the PDF or the Word document should be corrected. 
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Software Installation and Configuration 
Word Processing Software 
Accessible PDFs may only be generated from Word 2000 or later but other word processing software may 
be used to create the original documents. Other than the normal installation of Word, no special plugins or 
installation methods are needed to enable it to generate accessible PDFs. 

Adobe Acrobat 5 
Install Adobe Acrobat 5 as one would normally do. You may also wish to upgrade to the latest version — 
at the time of writing, is version 5.0.5 and is available as a free download 
(http://www.adobe.com/support/downloads/detail.jsp?ftpID=1309, 8.9 Mb). 

Configure the PDFMaker Macro 
When Acrobat is installed, it inserts two buttons on the toolbar of Word and a new menu item Acrobat to 
the right of the Help menu. The toolbar and menu item have been generated by a macro created by Adobe 
to tie into Microsoft Word and enable it to produce PDFs — the macros have been embedded within a 
document template called PDFMaker.dot which is installed with Acrobat and loads automatically each time 
Microsoft Word is launched. This section will deal with the configuration of the PDFMaker macro to create 
accessible PDFs as well as setting other options used for Publication Release Notices. 

The default settings of the PDFMaker macro enables the creation of PDFs with the simple click of a button 
but the default configuration will not create accessible PDFs — modifications to the default settings are 
necessary. 

 
Acrobat menu to the right of the Help menu and the Acrobat buttons to the right of the main 

toolbar. 

Using the menu, select Acrobat>Change Conversion Settings. There are four predefined Acrobat conversion 
settings, eBook (default), Press, Print and Screen found in the Settings tab of the Acrobat(R) PDFMaker 5.0 for 
Microsoft(R) Office dialog box. Any of these predefined profiles may be configured to produce accessible 
PDFs — the primary differences between them deal with colour depth, figure resolution, figure 
compression schemes and font embedding. 

 
The default conversion setting is eBook. Open the list (click on the down-pointing triangle) 

and select Print. 

The Print setting is closest to what we need for the Publication Release Notices but modifications still 
need to be made to the default settings of the Print profile (internally, these are called job options). From 
the Conversion Settings list, choose Print and click on the Edit Conversion Settings button below the list. 
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Select Acrobat 5 (PDF 1.4) from the Compatibility list. 

Select Acrobat 5.0 (PDF 1.4) from the Compatibility list. This feature will enable PDFMaker to generate a tagged 
PDF. Three other settings are needed for the purposes of Publication Release Notices: enable the Optimize 
for Fast Web View option, enable the Embed Thumbnails option and change the Resolution setting to 300. The 
remaining tabs across the top of the dialog box, Compression, Fonts, Color and Advanced, may be left as they are 
— the default settings within those tabs of the Print profile are fine. 

Click on the OK button and you will be prompted to save the changed profile under a different name. The 
pre-defined conversion profiles are set to Read-only: you must save your new profile under a different 
name. Type a new name for your settings (I have called my settings ODA) and click on the Save button — 
the filename extension .joboptions, will be added to the end of the name you give to your new job options. 

 
Saving a new .joboptions profile. 

After saving, you will be returned to the Settings tab of the PDFMaker dialog box. 

Click on the Security tab of the PDFMaker dialog box. The only option in this tab related to accessible PDFs is 
the Enable Content Access for the Visually Impaired — this option must be enabled, as is shown, so that the screen 
readers and Braille devices may access the text and deliver it via their technologies to the user. The other 
options shown are for the purposes of the Publication Release Notices. 

Guide to Editors of Accessible PDFs – Page 4 



 
The Security tab of the PDFMaker dialog box. 

No password is necessary to open the documents (Publication Release Notices) but the documents are 
protected from unauthorized changes. The Allow Content Copying and Extraction option may seem a bit 
confusing as it appears to be related to the Changes Allowed and Printing options below it but that is not the 
case. The Allow Content Copying and Extraction option enables or disables the users ability to click and drag 
across text within the document and copy the selected text to the clipboard. For the purposes of the 
Publication Release Notices, this may be enabled. The Changes Allowed option is set to None to prevent 
unauthorized changes to the document and Printing is Fully Allowed. 

From the Office tab (referring to Microsoft Office), enable and disable the options as shown here. The only 
option with regard to accessibility is the last option, Embed Tags in PDF, which must be enabled. 

 
The Office tab of the PDFMaker dialog box. 

From the Bookmarks tab, you must enable the first option, Convert Word Headings to Bookmarks, to make an 
accessible PDF. 
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The Bookmarks tab of the PDFMaker dialog box. 

The Bookmark Destination Magnification option is set to Inherit Zoom which means that whatever zoom setting is 
currently in place, either by the user or by the PDF document, will continue to apply when the user selects 
a bookmark. This option can be used to force the zoom setting of the document to a particular setting 
when a bookmark is selected — we have chosen not to force a different setting. 

Switch to the Display Options tab of the PDFMaker dialog box. For the purposes of accessible PDFs, there are 
no functions here that have any impact on the accessibility of the PDF. However, for Publication Release 
Notices, ensure that the options are set as shown here. The current standards of PSS are that Publication 
Release Notices should be set to open with the thumbnails visible but that is not an option that may be set 
here — it must be set after the PDF has been generated. Also, set the Open Magnification to Fit in Window. 

 
The Display Options tab of the PDFMaker dialog box. 
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After having set these options, return to the Settings tab and ensure that the Conversion Setting you had created 
is the one visible in the Conversion Settings list. This will ensure that when you create a PDF, this is the 
setting that will be used. Click OK when finished. 

The final step in creating an accessible PDF is to verify the accessibility of the PDF which can only be 
done from within Acrobat. To simplify the process of loading the newly created PDF into Acrobat, we 
will enable the option View Result in Acrobat. To enable this option, select Acrobat>View Result in Acrobat from the 
Acrobat menu in the Word menu bar. 

 
Select View Result in Acrobat from the Acrobat menu. 
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Reviewing the Word Document for Accessible Authorship 
The first step in ensuring that an accessible PDF may be created from the Word document is to verify that 
proper authoring techniques have been applied. 

Maintain Style While Changing Structure 
Style does not matter for accessibility but structure does. Therefore, when you need to fix something in 
the document, note the styles that have been applied to the structure, correct the structure then reapply the 
styles. For example, if a Heading 4 appears after a Heading 2 with no Heading 3 between, the Heading 4 
must be changed to a Heading 3. However, if the Heading 4 has been styled differently than the default 
Heading 4 style — such as 12 point text instead of 14 point text — then make note of the style, change 
the heading level to 3 and then restyle it to 12 point so that it looks the same as it did before but now has 
the proper structure. 

Using the Styles and Formatting Panel 
It is very beneficial to use the Styles and Formatting panel to help review the headings. To open the panel, 
select Format>Styles and Formatting… and the panel will appear to the right of the screen. At the bottom of the 
Styles and Formatting panel, select Available styles from the Show list and the panel will list the styles used in the 
document. 

 
The Styles and Formatting Panel appears on the left side of the Microsoft Word application 

window. 

Move your mouse pointer over one of the styles and hover for a couple of seconds. A tool tip will appear 
listing the styles that have been applied to the format underneath the mouse pointer. This is beneficial 
because it is easier to gather this information from the tool tip than to check through all of the menus and 
record the settings. If you have to change a Heading 4 to a Heading 3, you can compare the Heading 3 
and 4 styles, noting the differences and when you change the format of Heading 4 to 3, you can then go to 
Format>Font or Format>Paragraph to re-apply the styles 

Headings 
The first check I run through are the headings. I check that: 

• Heading 1 has been used only once, 

• Heading 1 is the first heading in the document, and; 

• the rest of the headings are used in order. 
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Heading 1 
The first heading used in the document must be Heading 1. Using the Styles and Formatting panel, move your 
mouse pointer over Heading 1 then click on the down pointing triangle to the right. You should see 
"Select All 1 Instance(s)" which means that Heading 1 has been used only once. Click on the "Select All 
1 Instance(s)" option and you will be taken to the Heading 1 block. Ensure that no other Heading levels, 
such as Heading 2, appear before it. 

If it appears that another heading has appeared before the Heading 1, click within the suspicious block of 
text and look at the Styles and Formatting panel: the style in use within that block will be highlighted with a 
box around it. Determine what formatting would be appropriate for the block and either select it from the 
styles and formatting list or create a new format. After applying the format, re-apply the styles that were 
previously applied to it, using the Font or Paragraph dialog boxes, so that the style of the text hasn’t 
changed, just its format or structure. 

If multiple instances of Heading 1 are found, select the "Select All x Instance(s)" (where x is the number 
of instances) and then scroll through the document looking for those other instances. Attempt to 
determine what format should have been applied instead of Heading 1 and apply it, then reapply the 
previous styles so that it looks the same. If it appears that the text should be another heading level but it is 
not clear which one, skip it for now and return to it when you have examined the rest of the headings. 

Headings 2 to 6 
It is valid to have multiple instances of the other heading levels so therefore, the "Select All x Instance(s)" 
for these heading levels doesn’t help much. Generally, I then start with the Heading 1 block and click on 
what appears to be the next heading to ensure that it is Heading 2: if not, I correct the structure and re-
apply the style. I continue to click within each of the "visual" headings to ensure that (1) they are 
structured in order and (2) that none of them are simply faked headings out of highly-styled paragraphs. 
You must also evaluate the content within the headings to ensure that similar content is grouped within 
the same heading. For example, if "Hard Copy Maps" was Heading 3, "80 000 Series Maps" and "60 000 
Series" maps should both be Heading 4 and "Digital Maps" should be Heading 3 because it is different 
from "Hard Copy Maps" but both may be under the umbrella of "Maps". 

Essentially, you are determining the document tree from the content and ensuring the headings are 
organized properly considering the content within them and other headings at the same or different levels. 
If you have any questions about the author’s organization of the headings, contact the author and discuss 
the organization of the content and the headings. 

Where it is clear that the headings should be changed, apply the correct heading level and then re-apply 
the original styles. 

Repeated Headings at the Top of Pages 
Headings that are repeated at the top of multiple pages are not true headings although the first instance 
may be. Repeated headings should be moved into the header area of a page which often means that at the 
end of the previous page, a new section break must be inserted, a header must be created from the 
repeated heading text and then the "Same as previous" options for headers should be examined to ensure 
that the style of the resulting pages is the same as previously. 

Paragraphs 
The only aspect of paragraphs I examine thoroughly are whether or not there are empty paragraphs 
although tabs for indenting and extra spaces are identified but rarely are they encountered. To do so, I 
enable the Show/Hide option to display the ¶ character whenever there is a new paragraph. If there are 
any empty paragraphs, I delete the paragraph and format the paragraph (either the one above or below 
depending on the circumstance) with spacing above or below it. Generally, if the font size is 11 point, I 
use 12 point spacing which is close enough. 

If there is an empty paragraph between two tables, I leave it alone temporarily and come back to it later. 
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The Paragraph format dialog box enables you to set the Indentation and Spacing options. 

Images 
Image must have alternate text. Because Word 97 does not have the options that enable the authors to 
insert alternate text, I examine the figure and determine what would be suitable. If the figure is of 
graphical text or has text in it,  I use the text as alternate text. Otherwise, I must determine what text is 
appropriate. Alternate text must describe the figure but does not need to overlap either caption text or 
surrounding description. If the figure shows a survey area and the caption or surrounding text states that 
the survey area is Shaw township, all that is necessary for alternate text may be "Map of survey area". 
However, if the caption or surrounding text assumes that the reader can interpret the figure, then a 
description is necessary. For example, if the caption states "Based on the results in this figure, we 
recommend drilling", then the figure needs explanation so that the user of screen reader software can 
either agree or disagree with the conclusion. 

To insert or verify alternate text, double click on each graphic, click on the Web tab and either verify or 
create the alternate text. 

 
When describing a figure, take into account the type of graphic and what the caption and/or 

paragraphs around it say about the graphic. It is not necessary to repeat the information. 
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Graphic Lines 
Where possible, remove graphic lines and replace them with top or bottom borders. You may increase the 
space between the border and the text to which it has been applied by clicking on the border and dragging 
it. 

Tables 
Ensure that any tables in the document have been used properly. If a table does not contain tabular data, 
then likely, it should be replaced with another format or structure. 

Tabular Data 
For clarity, any cells at the top of the columns or to the left of the rows that appear to be header cells 
should be formatted differently than the data cells either with shading (use light colours or greys) or bold 
or font size or typeface. There is no way to structure table header cells from with Word, just style them. 

Headings in Tables 
It is recommended that you take heading-like text out of the top merged cell of a table and place it on its 
own as a standard heading. However, this will significantly change the appearance of the text; you may 
wish to consult with the author on this and explain why the change is recommended. This may also solve 
a problem with an empty paragraph between two tables. 

Layout Tables 
Look for any uses of tables whose purpose is solely for layout, for example, placing two figures side-by-
side. Commonly, layout tables have their borders disabled so they are not easy to spot. Try to reduce the 
dependence on tables for layout and change to columns instead. 

Tables for Style 
Occasionally, tables will be used to place a box around content. Cut the content out of the table cell and 
delete the table. Paste the content box and with the drawing tools, draw a box around the content and 
place the order of the box to behind the content (to the back). This will create the same appearance but 
without the table structure. 

The Use of Colours 
It is uncommon that colours are used in the documents created by Publication Services Section. However, 
if you see colours in text or in a figure, ensure that the contrast of the colour against the background is 
high, ensure that any background colours are light and read surrounding text to ensure that there are no 
reference to the colours. 

Footnotes/Endnotes 
Footnotes and endnotes cause a problem for accessible PDFs but there is nothing you can do about it in 
Word other than to make note of whether or not footnotes/endnotes have been used, how many there are 
and where they are in the document so you can be prepared for them when you need to fix them in the 
PDF. 

Special Characters 
Some fonts do not work properly in accessible PDFs such as Common Bullets. Look for unique 
characters in the document as either footnote/endnote reference characters, in the body text or as custom 
bullets. At this time, it is known that the Common Bullets font is a problem but there may be others. With 
the author’s permission, replace any Common Bullets characters with others from another font. When the 
PDF is generated, watch for the font character error and make know of any fonts that also cause this 
problem. 
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Generating the PDF 
Once Word and Acrobat have been installed and properly configured and the Word document authoring 
for accessibility has been verified, most of the effort to create an accessible PDF been completed. The 
next sections deal with the generation of the PDF, running the Acrobat Accessibility Checker and fixing 
accessibility issues found by the checker. 

PDF Generation Methods 
There are two methods to generate a PDF from Word: print to Acrobat Distiller or click on the PDFMaker 
button. Printing to Acrobat Distiller will not create a tagged PDF which means that it will not be 
accessible. 

The only possible issue with PDFMaker is if you have not selected the proper profile or job option to create 
accessible PDFs. If you routinely generate PDFs that require other settings, you may have to switch 
between the two job options. To select the correct job option for accessibility, select Acrobat>Change 
Conversion Settings and select the correct Conversion Setting from the list. The only other Acrobat issue that 
might be encountered during the creation of the PDF is the one relating to the margin and footer 
measurements but this has been dealt with in the previous section. 

Once the PDF has been generated, it will be opened in Acrobat. If it does not open in Acrobat but ask you 
for a filename instead, save it then open it. However, the next time you generate a PDF, you may wish to 
enable View Result in Acrobat from the Acrobat menu in the Word toolbar. 
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PDF Tags and Elements 
The Accessibility Checker installs with Acrobat 5 under the Tools menu. However, you will also need to 
work with the PDF tags — PDF tags are not visible by default. To view the PDF tags, select Window>Tags. 
If the Tags palette is a floating palette, you may drag it to the palette group (often on the left side of the 
application and dock it with the rest of the palettes. 

The Tags Palette 
An accessible PDF will have PDF tags and the Tags palette will appear as below showing the Tags Root. If 
there are no PDF tags present, you will see No Tags available instead. 

 
The Tags palette (currently open) has been docked with the other palettes on the left side. 

The Tags Root is visible indicating that PDF Tags have been created. 

The Tags Root has a plus-symbol beside it indicating that it may be expanded to show the components of 
the document within it. Click on the plus-symbol to expand the component or click on the minus-symbol 
to contract it. 

 
The left figure shows a document with a single Section (<Sect>), the middle figure shows 
the headings, paragraphs and other components of the document within the Section and 

the right figure is taken from a different document which has two Sections, and each 
section will have headings, paragraphs and other document components (not visible). 

Each tag has properties which may be modified. To access the properties of a tag, you may either right-
click on a tag or click (left-click) on a tag to select it, then click on the Tags drop down menu from the top 
right of the Tags palette. 
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Whether you right-click on a PDF tag (left) or select a tag and click on the Tags drop down 

menu (right), the options are essentially the same — the one additional item available 
through the drop down menu is of no concern to us. 

Note that despite the fact that we are looking at the Tags palette, the menus refer to Elements. A 
representative from Adobe mentioned in a workshop that PDF tags are much like HTML tags. At times 
HTML tags are referred to as elements also. For example, the HTML paragraph tag, <p>, consists of the 
angle brackets, "<" and ">", and the element "p". At times, this document will refer to tags and other 
times elements depending on how the terms are used in Acrobat. 

The only three items that will be used from this menu are Element Properties, Find Unmarked Comments and Turn 
On Associated Content Highlighting. 

Modifying Element Properties 
From the Tags menu (either right-click on a tag or left-click once on a tag and click on the Tags drop-
down menu), choose Element Properties from the menu list. Of all the options available, this dialog box will 
primarily be used to set the language of the document or insert Alternate Text. 

 
The Element Properties dialog box is used to set the language of the document. 

Find Unmarked Comments 
Select Find Unmarked Comments (not Find Unmarked Content which is very similar in name and function but not 
suited to our purposes here) from the Tags menu. This dialog box has two functions — to find an 
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unmarked comment and then, once found, to tag the unmarked comment. This dialog box will be used to 
locate and tag footnote links for which no PDF tags have been created. 

 
The figure on the left shows the Unmarked Comments dialog box before the find process is 

activated. Once an unmarked comment has been found, it will be identified and you are 
given the option to create the appropriate tag for the found comment. 

Locating a Specific PDF Tag 
In a long document, such as this one, there are many PDF tags and if it is necessary to locate the correct 
tag for a particular item, it may take a fair bit of effort. There is an option within the Tags palette which 
simplifies the search. Click on any tag (other than Tags Root), then either right-click or click on the Tags 
drop down menu and select Turn On Associated Content Highlighting. Notice that a black box surrounds the 
selected item in the PDF document. As you click on other PDF tags from the Tags palette, the document 
will scroll up or down to show the selected component of the document. 

 
In this figure, the Heading 1 PDF tag has been selected and the Heading 1 text within the 

PDF document has a black box around it. 

While this highlighting function is enabled, the other menu items from the Tags menu (drop-down or 
right-click) are not available — you must disable the highlighting function to access the other menu items 
such as changing Element Properties. 

 
While the content highlighting function is on, other menu items are unavailable until 

associated content highlighting has been turned off. 
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Open with Thumbnails 
Although, with practice, an accessible PDF may be generated without errors requiring no fixing or 
changes to the completed PDF, there is one option that must be changed for the purposes of the format of 
Publication Release Notices. As a result, it is necessary to temporarily disable the security options so that 
the change may be applied. To do so, in Acrobat, select File>Document Security. Press Tab and type the 
password and click OK, then click Close to close the Document Security dialog box. You have now 
temporarily disabled the security allowing you to make changes to the PDF. When you save the document 
however, the security settings will apply again. 

For the purposes of Publication Release Notices, the format is to have the release notice open with the 
thumbnails visible. Although it is possible to configure PDFMaker to have the PDF open with its 
Bookmarks visible, there is no option to have the Thumbnails visible — it must be configured from the 
final PDF. Select File>Document Properties>Open Options and enable the Thumbnails and Page option from the Initial 
View group, select Fit in Window from the Magnification options and click OK. 

 
Set the Initial View to Thumbnails and Page and click OK. 
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Checking for Accessibility 
Select Tools>Accessibility Checker from the menu. Disable the Create Logfile and Create Comments in Document 
options if either or both are enabled — either one may be enabled later if needed but as you become more 
proficient at creating accessible PDFs, you will have less and less need for comments or log files. Click 
OK to run the Accessibility Checker. 

 
Disable the Create Logfile and Create Comments in Document options — either may be 

enabled later if needed. 

Using Comments with the Accessibility Checker 
If the Create Comments in Document option has been enabled, any items that raise an accessibility flag will be 
marked with a comment within the PDF document. The comment will briefly describe the issue and mark 
the item (paragraph, character or image) with a box around the item to identify which item is at issue. 

The comments are shown within the Comments panel (click on the Comments tab to open the Comments 
panel) — the comments are listed by page number. Click on the plus-symbol to the left of the page 
number to see the comments within a particular page. To delete a comment, click once on it and either 
press the Delete key, click on the Trash can icon at the top of the Comments panel or right-click on the 
comment and choose Delete from the drop-down menu. All of the comments on a page may be deleted 
together by first clicking on the "Page xx" line, then deleting it using any of the methods mentioned 
above. 

In the Comments panel, the page on which the accessibility issue exists is identified. The item is also 
identified within the PDF document — a box is drawn around it by the Accessibility Checker. 

 
On the left, the Comments palette is open and Page 1 has been expanded displaying the 

comments located on that page. On the right, within the PDF document, the red box is 
drawn around a graphic line for which there is no alternate text. 
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Common Accessibility Problems 
The following dialog box identifies the commonly encountered issues generated by the Accessibility 
Checker. 

 
Common accessibility issues raised by the Accessibility Checker. 

Some of the corrections are best done on the original Word document from which a new PDF document 
must be regenerated. Other corrections are best done within the generated PDF document — for these 
corrections, remember to disable the security protections so that the changes may be applied to the PDF 
document. 

xxx text block(s) with no language specified 
If there is more than one language setting within the document, the PDFMaker macro does not assign a 
language to the document. There are only two solutions to this problem. You may go back to Word and 
assign a single language to the whole document despite blocks that may be in a different language, then 
regenerate the PDF. The other solution is to assign a single language to the document through modifying 
the properties of the PDF Section <Sect> tag. 

If you choose to assign a language property in the PDF, open the Tags Root by clicking on the plus-
symbol to its left. Open the Element Properties dialog box for the Section tag by either right-clicking on the 
Section tag <Sect> or click once on it, then choose Element Properties from the Tags menu. From the 
Language list, select (or you may type) either EN for English or FR for French and click OK. If there are 
multiple Sections, each must be assigned a language. It is not possible to assign a language to the Tags 
Root — the largest division within the Tags Root are the Sections. 

By assigning a language to the Section, everything within the section will take on that language property. 
You may, if so desired, select a <Normal> tag within a section and apply a different language if it is 
appropriate. However, although it is possible to apply a change of language to an individual word, a group 
of words or a sentence within a paragraph, it is very tedious and time consuming and there currently is no 
value to doing this; JAWS does not switch language settings on the fly within PDFs although it will in 
Web pages. 

xxx element(s) with no alternate text 
This issue appears when one or more graphics have no alternate text. If you have only one graphic in the 
document, it is clear which one is the source of the issue. However, if you have more than one graphic, it 
may not be clear which one(s) are missing alternate text. It should be noted that the best fix for this issue 
is to return to the Word document and add alternate text to the graphic(s) so that if you ever need to 
regenerate the PDF, the alternate text will be embedded into any future versions of the PDF. 

To locate the graphic(s) without alternate text, you must rerun the Accessibility Checker with the 
Comments option enabled — this options will mark the image enabling you to find it easily. Scan through 
the document to identify which graphics need alternate text. 
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This graphic line has been flagged by the comment option of the Accessibility Checker as a 

graphic element that needs but does not have alternate text. 

If you must add alternate text in the PDF and if you have flagged the graphic(s) by running the 
Accessibility Checker with comments enabled, remember to delete the comments before saving the PDF 
otherwise you will have created content that is outside of the structure tree. However, if you ran the 
Accessibility Checker again without deleting the comments, the alert box would indicate this anyway. 

In addition to images, graphic lines (as shown in the above figure), may also raise accessibility issues — 
they too require alternate text. As was discussed in the earlier section on verifying the Word document for 
accessible authoring, lines are best "drawn" as borders which do not raise accessibility issues. 

If it is necessary to add the alternate text to a graphic line from within Acrobat, you must first locate the 
PDF tag for the graphic line: graphic lines are tagged with the <Shape> tag. To locate the tag, expand <Sect>, 
look for the <Shape> tag, right click on it, select Turn on Associated Content Highlighting and the shape associated 
with the selected <Shape> tag will be selected. If this is not the <Shape> tag for the problematic graphic line, 
look for other <Shape> tags in the list, click on them one by one until the <Shape> tag for the problematic 
graphic line has been found. Right click and select Turn off Associated Content Highlighting. Right click on the 
<Shape> tag once again and select Element Properties. In the Element Properties dialog box, type "--" in the 
Alternate Text field and click OK. As you can see, it is easier to create a border line where possible but if a 
border line is not possible, you must use this procedure to add alternate text to graphic lines. 

xxx element(s) inaccessible because they are not contained within the structure tree 
This complex description means that there is a part of the document for which no PDF tag has been 
created — as a result, that part is not within the structure tree or tag tree. This message has only been 
encountered when footnotes have been used within the Word document. 

Within Word, footnotes behave like "in-document hyperlinks" — click on a footnote reference and you 
are taken to the footnote text. Within the PDF document, this linking action works just as it does in the 
Word document. However, the link has no PDF tag which is the source of this error. The link is 
associated with the superscript footnote reference — this is important to understand because as we go 
through the process of creating the missing tag, the new tag should be associated with the superscript 
footnote reference, not the paragraph or the page or the section within which the footnote reference exists. 
Sometimes, however, the superscript tag is not created and as a result, you cannot create a PDF link tag 
against it — therefore, you must apply the link tag to the next highest tag, in most cases, the paragraph or 
<Normal> tag. 

It should be noted that if the PDF has been marked up with notes, comments or new hyperlinks after the 
PDF has been created, these too will produce this same error message. Any of these items, if added after 
the PDF has been created, will not have a PDF tag and therefore will not be contained within the structure 
tree. If comments or hyperlinks are necessary, they should be created within the Word document, not after 
the PDF has been created. 

It should also be noted that if a link’s destination is wrong — for example, a misspelled e-mail address — 
the link’s destination may be corrected without raising this issue. In doing so, we would not be creating a 
new link, just modifying an existing one. 
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Creating the Missing PDF Link Tag 
The procedure for correcting this error must be done from within the PDF document — it appears that an 
error or bug within the PDFMaker macro is responsible for its inability tag the footnote link properly and 
until the macro has been repaired, it will always fail. 

The process of correctly adding the missing PDF <Link> tag is quite involved. The steps of the process are: 

• locate the unmarked link (referred to within Acrobat as an unmarked comment) but do not tag it, 

• locate the superscript tag for the footnote marker within the Tags tree and, finally, 

• return to the Find Unmarked Comments function and add the missing link tag. 

Searching for Unmarked Comments for the First Time 
From the Tags menu, select Find Unmarked Comments. Set the dialog box to Search Entire Document for Unmarked 
Comments as is shown in the figure below. Click on Find Next and the function will stop at the first found 
unmarked comment and mark it with a box around it. In the Found Comment area of the dialog box, it states 
Comment Type: Link — there may be other types of found comments, links are the only ones we are 
concerned with and that I have had experience with. Note the page on which this unmarked comment link 
exists. Do not create a PDF tag but click on the Find Next button and record all other instances of found 
unmarked comment links. 

 
The Find Unmarked Comments dialog box found the footnote link on page 10 and 

surrounded the superscript footnote marker with a box. 

Locating the Superscript Tags Within the Tags Tree 
From the Tags menu, select Turn On Associated Content Highlighting. Click through the tags until you locate the 
paragraph (the <Normal> tag) in which the footnote marker exists. Click on the plus-symbol to the left of 
the <Normal> PDF tag to expand it and display the <Superscript> tag. Click once on the <Superscript> tag to 
select it, then from the Tags menu, select Turn Off Associated Content Highlighting. If the <Superscript> tag does not 
exist, select the <Normal> tag instead. 
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The paragraph has been located and the superscript footnote marker has been selected. 

Applying the Link tag to the Unmarked Comment 
Before applying any of the steps in this part of the process, ensure that the <Superscript> (or <Normal>) tag in 
the Tags tree is selected — this will ensure that when the link tag has been created, it will apply to the 
superscript footnote marker or the paragraph within which the footnote marker exists. 

From the Tags menu, select Find Unmarked Comments once again. This time however, ensure that the Search 
Current Page for Unmarked Comments option is selected to restrict the search to the current page. Click on the 
Find Next button and the superscript footnote marker will be highlighted again.[2] You may have to move 
the Unmarked Comments dialog box out of the way to see the selected footnote marker within the PDF 
document. 

From the Tag Type list at the bottom of the Unmarked Comments dialog box, select Link and click on the Create 
Tag button. You may now click the ⌧ button (Close button) at the top right corner of the Unmarked 
Comments dialog box. 

 
In this figure, the superscript tag has been selected in the Tags tree, unmarked link has 

been relocated in the PDF document and highlighted with a box around it, the Unmarked 
Content Type has been identified as a Link, "Link" has been selected from the Tag Type list 
and the Create Tag button has been pressed. Note that the Tags tree shows that the new 

<Link> tag is a subordinate to the <Superscript> tag. 

This completes the process for properly assigning the Link tag to the first superscript footnote marker. To 
continue to correct the rest of the footnotes, consult your notes for the page location of the next footnote 
marker and continue with the Locating the Superscript Tags Within the Tags Tree step above. The last two steps 
have to be applied to each footnote marker until all have been corrected. 

Why Attach the Link tag to the Superscript tag? 
PDF tags serve two purposes: to identify the structure of a PDF document and also to specify the reading 
order. JAWS will read the PDF according to the order of the PDF tags. Therefore, if the <Link> tag is 
created anywhere else, it will not be in proper reading order which is why so much effort is placed on 
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ensuring that the <Link> tag is associated with the <Superscript> tag. Although it is possible to re-order PDF 
tags that are out of order, why go to the extra trouble when all you need to do is to set up the right 
conditions for the <Link> tag to be created in its proper place. 

xxx words inaccessible because they contain characters with no reliable mapping to 
Unicode 
This message appears when a font does not reliably map to Unicode such as the Common Bullets font. 
There is no known PDF fix for this: the character must be deleted from the original Word document and 
replaced with a character from another font, one that does not cause problems. Experimentation will 
determine which fonts create this error and should be avoided. 

As was mentioned earlier, the font character does appear in the PDF document but it is not accessible. 

+ No comments could be attached 
This message appears when the Create Comments in Document option in the Accessibility Checker has 
been enabled but the PDF document’s security options prevent changes to the document. This message 
appears when the Accessibility Checker has been run before document security has been disabled. The 
alert box containing the summary of accessibility issues will still appear but no comments will have been 
inserted into the document. Cancel the alert, disable security and rerun the Accessibility Checker. 

No Accessibility Issues 
After correcting the issues raised by previous runs of the Accessibility Checker, you will be relieved to 
see the following alert from the Accessibility Checker. 

 
This alert is what you are working towards — no accessibility issues within the PDF. 

However, as accessibility features mature, other items, such as document structure which may now be 
overlooked, may generate accessibility alerts. Be aware of accessibility issues raised in future versions of 
Acrobat. 
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Summary 
Creating an accessible PDF is not very difficult — with practice and familiarity with the accessibility 
issues, features of Word and use of the Tags palette, the process of creating an accessible PDF takes very 
little effort. 

The basic process of creating an accessible PDF is as follows. 

1. Document Structure; 
a) Use proper headings. 
b) Use proper lists. 
c) Use tables for tabular data, not for formatting or style. 
d) Use one of the predefined templates for Publications Release Notices to ensure that the 

language setting is consistent. 

2. Document Styles; 
a) Use styles to modify font, font size, colour and paragraph spacing. 
b) Use boxes in place of tables for style. 

3. Images and Lines; 
a) Add alternate text to all graphics. 
b) Use border properties rather than graphic line; 

i) If you must use graphics lines, make certain they have alternate text. 

4. Generate the PDFs using the PDFMaker macro. 

5. Check the PDF for Accessibility; 
a) Correct any accessibility issues that are raised by the Accessibility Checker. 

 
You should remember that there are three aspects to creating accessible PDFs: 

• you must be aware of software and hardware issues such as the features of screen readers and 
how they work,  

• you must be aware of the barriers (disabilities) for which accessibility initiatives try to 
accommodate, and; 

• accessibility cannot be verified just using automated checkers, authoring practices must be taken 
into account. 

Knowing that sighted readers skip from heading to heading visually and that screen readers can be 
prompted to do the same will help you understand why headings are so important. Realizing that blind 
and colour-blind persons cannot see colours or can disable colours in Acrobat Reader will stop you from 
writing "the items in red are new". As with everything in life, knowledge helps with understanding: 
knowledge about disabilities and assistive technologies helps you to understand why certain techniques 
are employed and to think of solutions when new situations arise. 

You should also remember that there are both automated checks and manual checks for accessibility. It is 
wrong to rely on automated checks alone because of weaknesses in the checking process (the 
Accessibility Checker does not check for the presence of headings) and errors in judgements (the PDF 
may create a document with incorrect reading order). Knowledge and understanding of impairments and 
assistive technologies will assist with the manual checking. 

 
1 I would like to acknowledge the assistance I received from Rob Bender of the Canadian Institute for the Blind 
(Sudbury). 



Guide to Editors of Accessible PDFs – Page 24 

                                                                                                                                                                           
2 Even if the <Normal> tag was selected in the previous step, when running the Find Unmarked Comments function, 
the superscript footnote reference will be selected from within the paragraph and the PDF link tag will be created 
against it. 
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